Thread: New at psp moddin

Results 1 to 12 of 12
  1. #1 New at psp moddin 
    Member PSP User hbk069's Avatar
    Join Date
    Jan 2007
    Posts
    61
    I had my psp for a long while, I always wanted to know if I can take my psp to the next level and perhaps play some old ps1 games. I know I can download psx games but I am not so quite sure which firmware to use. I downloaded dat new 3.03 from the sony site or something. I also own a modded xbox, which is really fucken cool, too bad the xbox 360 cannot act as a PC yet, crap. I hope I can get better use of my psp cuz it just sits in my room.
    Reply With Quote  
     

  2. #2  
    Senior Member I Modded My PSP tahval's Avatar
    Join Date
    Oct 2006
    Posts
    376
    ok, if you have the new sony 3.03 you can't play ps1 games without a ps3.
    To play ps1 games without a ps3, you need the custom firmware 3.03OE-A2
    ...
    Reply With Quote  
     

  3. #3  
    Member PSP User hbk069's Avatar
    Join Date
    Jan 2007
    Posts
    61
    where would I get this 3.03oe-a2 at, I currently have the 2.60 firmware... I downloaded dat Dark_AleX's latest release of 3.02 OE-A
    Reply With Quote  
     

  4. #4  
    Senior Member I Modded My PSP tahval's Avatar
    Join Date
    Oct 2006
    Posts
    376
    ...
    Reply With Quote  
     

  5. #5  
    Member PSP User hbk069's Avatar
    Join Date
    Jan 2007
    Posts
    61
    I dont have the 1.50 firmware
    Reply With Quote  
     

  6. #6  
    Senior Member I Modded My PSP tahval's Avatar
    Join Date
    Oct 2006
    Posts
    376
    ...
    Reply With Quote  
     

  7. #7  
    Member PSP User hbk069's Avatar
    Join Date
    Jan 2007
    Posts
    61
    i CANT downgrade to 1.50
    Reply With Quote  
     

  8. #8  
    Senior Member I Modded My PSP tahval's Avatar
    Join Date
    Oct 2006
    Posts
    376
    Quote Originally Posted by hbk069
    i CANT downgrade to 1.50
    why can't you? you have 2.6.
    ...
    Reply With Quote  
     

  9. #9  
    Member PSP User hbk069's Avatar
    Join Date
    Jan 2007
    Posts
    61
    I extracted the ta whatever and put it on E:\PSP\GAME\ with two folders idstoragechange and UPDATE... then I got the 150 file from the site u given me on this forum, and then i renamed the EBoot file to UPDATE and I put dat file under the update folder, did i mess up somewhere... when i run the idchange application on my psp, it gives me an error, same goes for the version xxx application
    Reply With Quote  
     

  10. #10  
    Member PSP User hbk069's Avatar
    Join Date
    Jan 2007
    Posts
    61
    I cannot get it to work, it still gives me an error
    Reply With Quote  
     

  11. #11  
    Member PSP User hbk069's Avatar
    Join Date
    Jan 2007
    Posts
    61
    All Im getting is the game could not be started {80020148}
    does this mean my psp is a brick?
    Reply With Quote  
     

  12. #12  
    Member PSP User hbk069's Avatar
    Join Date
    Jan 2007
    Posts
    61
    i used the gta trick to downgrade my oso 2.60 to 1.50
    Reply With Quote  
     

Similar Threads

  1. Need help with basic moddin
    By unstopaulble in forum PSP Software, Firmware & Plugins
    Replies: 12
    Last Post: 02-21-2009, 07:24 AM
  2. Okay i hit a wall moddin my battery
    By Konkor in forum PSP Hardware & Repair
    Replies: 5
    Last Post: 07-21-2008, 12:31 PM
  3. Some Q's to psp moddin
    By tony_2004 in forum PSP Discussion
    Replies: 15
    Last Post: 03-02-2008, 11:45 PM
  4. noob to moddin sayin hi
    By DS H8TR in forum Introduce Yourself
    Replies: 1
    Last Post: 02-11-2008, 07:46 AM
Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •