Thread: going to get a new psp

Results 1 to 7 of 7
  1. #1 going to get a new psp 
    Junior Member
    Join Date
    Feb 2007
    Posts
    4
    hey guys i recently found out i could play psx games on a psp and am looking into buying one...my friend says he has a version 1.0 psp but from what im reading the earliest version is 1.5, and thats the one i need to use dark alexs firmware....he said he bought his psp a year after they were released(USA) so im not sure what version it could be...

    if this turns out to be a moddable psp and i buy it i guess il be at this forum a lot=p
    Reply With Quote  
     

  2. #2  
    Retired Moderator PSP Elite Hacker Julie's Avatar
    Join Date
    Oct 2005
    Posts
    12,155
    theres 1.0 psp's but they are next to useless. as long as its not over fw 3.03, then you can run the custom firmwares
    R.I.P Zoidberg
    Reply With Quote  
     

  3. #3  
    Junior Member
    Join Date
    Feb 2007
    Posts
    4
    well fantastic i just found out my friend upgraded his firmware to 2.71 to play a umd.......useless
    Reply With Quote  
     

  4. #4  
    Retired Moderator PSP Elite Hacker Julie's Avatar
    Join Date
    Oct 2005
    Posts
    12,155
    2.71 can still be downgraded back to 1.50 to install the custom firmware though
    R.I.P Zoidberg
    Reply With Quote  
     

  5. #5  
    Junior Member
    Join Date
    Feb 2007
    Posts
    4
    UPDATE : If you were crazy enough to upgrade ur psp to a 2.1 or a 2.5 sigh.... YOUR SCREWED FOR homebrew apps
    Well for now till they hack it wich wont be for a loong time so dont ask how long.
    thats in the newbie area...i was assuming that anything past 2.5 would be bad aswell? This is not the case?
    Reply With Quote  
     

  6. #6  
    Senior Member PSP Elite Hacker bender123's Avatar
    Join Date
    Dec 2006
    Posts
    1,048
    Quote Originally Posted by makkunbakkun
    thats in the newbie area...i was assuming that anything past 2.5 would be bad aswell? This is not the case?
    nah, anything past 3.03 is impossible to downgrade. 2.82-3.03 is the most annoying cus you need the LCS unpatched UMD. It should all be explained in the Stickies...
    Please could you stop the noise, I'm trying get some rest
    From all the unborn chicken voices in my head
    What's that...? (I may be paranoid, but not an android)
    What's that...? (I may be paranoid, but not an android)
    Reply With Quote  
     

  7. #7  
    Junior Member
    Join Date
    Feb 2007
    Posts
    4
    awesome thanks!
    Reply With Quote  
     

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •