Thread: Its Been Awhile

Results 1 to 3 of 3
  1. #1 Its Been Awhile 
    Junior Member
    Join Date
    Apr 2010
    Posts
    5
    I used to be a pro at modding my PSP when it first came out. I had 1.5 fw on it along with some home brew. Then, my PSP was stolen.

    A couple years later, I bought another PSP fat, but cracked the LCD.

    It's been about two years since I've touched my system and finally decided I'd replace the LCD screen and install some cfw, but it's been so long and I need help.

    I have a PSP1000 with 3.71 fw. I do not have a Pandora battery or a magic memory stick. I have read through way too many tutorials and am getting irritated. I want to downgrade it back to 1.5, or atleast a fw where I can play nes, snes, sega, n64, and psone emulators. I have found a couple tutorials that gives me directions on how to softmod the battery, but I am a bit rusty on what cfw I need in order to do so. I've also used the search function and am a Mac OSX user.

    Can someone help out a born again noob? Here's some questions I have:

    1) What cfw can I use to play the above emulators? (Do I really need to downgrade back to 1.5?)

    2) If I plan on playing newer games, will I be able to play them and still keep the cfw? I am planning on using UMDumper to play games and watch movies straight from the memory stick.

    3) If I end up going the softmod battery route, what cfw do I need to install when I have 3.71 fw installed?

    Thank you in advance.
    Reply With Quote  
     

  2. #2  
    Elite Bullshitter PSP Elite Hacker Jubbabubba's Avatar
    Join Date
    Jun 2009
    Posts
    3,168
    Since you don't have a pandora and mms use the second link in my sig. With 5.50gen-d3 you can play the newest psp games, emulators and homebrew. Once you have cfw press select to open the bah menu and change the umd mod to m33 driver so you can play the psp games without a umd inserted.

    For psx games You'll need to install popsloader for 5.50 gen or 5.00m33 depending on the cfw you stick with.
    Reply With Quote  
     

  3. #3  
    Junior Member
    Join Date
    Apr 2010
    Posts
    5
    Thanks Jubbabubba.

    It took me awhile to install chickhen, not to mention I am doing this with a cracked screen and can't read much. I haven't received my new screen yet.

    Anyways, I was wondering if the emulators in the download section are compatible with CFW 5.50 Gen-D3. It's been awhile since I've messed with emulators and remember that certain ones are only compatible with certain fw. I downloaded the ones I wanted from the download section and have yet to install them. I've got a couple more questions if you don't mind helping me out. I will be searching online in the meantime.

    1) Is there a site that explains in detail the bah menu? I accessed it, but I want to fully understand every function.

    2) Do you have a link to homebrew/emulators dedicated strictly for CFW 5.50 Gen-D3? (Or is all homebrew/emulators capable of being used on that cfw?)

    Thanks again.

    EDIT: I just read "http://www.pspmod.com/forums/psp-beginners-forum/58941-psp-hacking-dummies-every-guide-psp-newbie-would-ever-need.html"
    Last edited by rontonsoup; 04-07-2010 at 01:42 AM.
    Reply With Quote  
     

Similar Threads

  1. been away for awhile need a little help
    By childsy_1985 in forum PSP Software, Firmware & Plugins
    Replies: 3
    Last Post: 04-10-2010, 11:28 AM
  2. Its been awhile ppl ;o)
    By raymi5 in forum PSP Discussion
    Replies: 0
    Last Post: 01-04-2010, 04:15 PM
  3. It's been awhile... need some help
    By akamurph in forum PSP Software, Firmware & Plugins
    Replies: 16
    Last Post: 10-21-2008, 07:59 PM
  4. Been Away Awhile
    By apathy96 in forum Introduce Yourself
    Replies: 4
    Last Post: 05-02-2008, 10:59 PM
  5. Its been AWHILE...Need HELP
    By Tawcoma26 in forum PSP Hardware & Repair
    Replies: 2
    Last Post: 03-11-2008, 05:45 PM
Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •