Thread: PS1/PSX emulator on PSP

Page 1 of 6 123 ... LastLast
Results 1 to 15 of 81
  1. #1 PS1/PSX emulator on PSP 
    Junior Member PSP User
    Join Date
    Jul 2008
    Posts
    13
    Currently now have a SLIM PSP with custom firmware 4.01 m33-2. Wondering whats the best PS1 emulator. Anybody also know of a great place to get ps1 roms.
    Reply With Quote  
     



  2. #2  
    Senior Member PSP Elite Hacker cheema201's Avatar
    Join Date
    Jun 2008
    Posts
    1,042
    you dont need an emulator to play psx games on the psp... the game needs to be put into an eboot format from a disc image. then the psp will be able to read the game

    there is a few things that you will want to do if you are looking at having psx games running well on your psp..

    first of all i suggest getting popsloader.. check out this link and follow the guide
    How To: Install Popsloader on 3.80 M33, 3.90 M33 - eXophase.com Forums

    now the next thing you need to do is create your eboot.. there are several programs which do this.
    many ppl swear by PSX2PSP and it is a great. however i personally use RS-GUI PopStationMD v3.00 most of the time..

    here is a tutorial on how to get that up and running
    PSP Hacking Guide - Part 7: PSX (PSOne) Games - “PopStation” | Blast Processing

    i believe those 2 things will have you well on your way to playing playstation games on your PSP.. and if you are interested in cheats then google search cwcheat and check that out..

    also about psx roms.. its not a great idea to ask about those sorts of things as it is a moral grey area since you should only download a rom of a game which you own.. remember that google is your friend and i can not give you any links in order to download games..
    Reply With Quote  
     

  3. #3  
    Junior Member PSP User
    Join Date
    Jul 2008
    Posts
    13
    Thanks for the quick reply Cheema. I will definitely try this out. Im sorry I created a new thread for this. Realized there was a similar question asked on a different thread. My apologies. Also, your right about the asking of roms and all that. Should of known better but I thought I'd try anyway. Thanks again.
    Reply With Quote  
     

  4. #4  
    Senior Member PSP Elite Hacker cheema201's Avatar
    Join Date
    Jun 2008
    Posts
    1,042
    Thats ok that you made a new thread.. it happens all the time.. i believe i have answered this question about 20 times now hahaha..

    if you need any help i will be online for the next hour or so... so let me know how you are going with it all.. and after you have done 20 or so posts then you can PM me if you have any problems with playstation games.. as its mainly wat i use my PSP for...
    Reply With Quote  
     

  5. #5  
    Junior Member PSP User
    Join Date
    Jul 2008
    Posts
    13
    Thanks Cheema. Really appreciate it. Im new to psp hacking but I've been learning a bit these last few days and getting more familiarized.
    Reply With Quote  
     

  6. #6  
    Senior Member PSP Elite Hacker cheema201's Avatar
    Join Date
    Jun 2008
    Posts
    1,042
    yeh no worries.. i like helping out. and your questions aren't hard to answer haha
    Reply With Quote  
     

  7. #7  
    Senior Member I Modded My PSP itzzspencer's Avatar
    Join Date
    Jun 2008
    Posts
    478
    well, thats good to know cheema, can you help me? my final fantasy 9 suddeny says that i have no save file, but i think i see it in my save data utility
    Reply With Quote  
     

  8. #8  
    Senior Member PSP Elite Hacker cheema201's Avatar
    Join Date
    Jun 2008
    Posts
    1,042
    do you have cwcheat?? you can manage your saves with that...

    now i haven't done it in a while but i do have a save game manager on my computer.. i'll have a look into it and find out some exact steps and then get bak to you about it..
    Reply With Quote  
     

  9. #9  
    Senior Member I Modded My PSP itzzspencer's Avatar
    Join Date
    Jun 2008
    Posts
    478
    ahh too late now right? i cant even load it lol
    Reply With Quote  
     

  10. #10  
    Senior Member PSP Elite Hacker cheema201's Avatar
    Join Date
    Jun 2008
    Posts
    1,042
    it doesn't matter if you cant load it.. as long as the save exists then we can probably fix it...

    check this out
    PSXMemTool

    see if that helps at all... once you download that try and hook it up to your PSP and find the save you are talkin about.. i cant do it at the moment as i do not have my PSP with me..

    once you have done that you will be able to use cwcheat in order to manage your memory card by changing the save to the particular code given to the game.. for instance if the code for the game was scus00125 or wateva then you would rename your saves accordingly. with the extension .mcr

    so look into that for now and if that is all too confusing let me know and i'll try give you some basic steps to follow
    Last edited by cheema201; 07-18-2008 at 09:00 AM.
    Reply With Quote  
     

  11. #11  
    Junior Member
    Join Date
    Aug 2008
    Posts
    1
    hey cheema

    im REALLY new to this psp modding stuff, my friends modded mine and im at 3.71, and the steps u put forth r pretty simple, but i dont get this m33 stuff, do i have to update my psp again and then follow these steps (update to 3.71 m33?)
    i reallly wanna playyyy ps1 games at full speed!!!

    anything wud help at this point, i know once i can solve that, ill b well on my way following those steps.
    Reply With Quote  
     

  12. #12  
    Junior Member PSP User
    Join Date
    Jul 2008
    Posts
    11
    Edited Post

    Hey Cheema201, sorry to break into the thread like this but I've read a decent amount of your replies and posts over the past couple weeks and you seem to be the man for PSX emulation. I've figured everything else out thanks to google. Unfortunately I can't search the forum because for some reason my computer won't display the image verification code, so forgive me for not being able to find help elsewhere on these forums. This is where my asking for help comes in:

    Popsloader and CWCheat. My PSP has become my GOD of playing PSX games, I DLed ISOBuster, CloneCD, ImpalersPSX and Ice Tea and have been making Eboots of my entire PS1 library. I've been having problems running certain Eboots because I'm only running the Popstation included in my CFW which is 3.71 M33-2. (I stuck with this because playing FF7 was my ultimate goal, seemed to be the best version to play it on.) I check the compatibility list, so I know I need different versions of Popstation to run some of my games correctly.

    So mainly here are my problems, if you can help me out it would be amazing:

    EDIT: Cheema I registered to the site to view the tutorial via your link to popsloader tutorial in your profile. It seems I can't run popsloader in 3.71M33-2, so now my questions is, if I plan to upgrade to 4.01M33-2 which CFW version of Popsloader should I DL? Will 3.80 or 3.90 work in 4.01M33-2? I notice this is the firmware you are running. (I have the .prx files I need, hopefully I can still use them after an update.)

    Will CWCheat work on 3.71 M33-2? EDIT: If I am to update to 4.01M33-2 should CWCheat work fine?

    EDIT: I'm also worried about upgrading affecting the performance of my other emulators like MVSPSP, Nester J, MasterBoy, Snes9xTYL, PicoDrive and others. They work perfectly now, I don't want to screw anything up. After I update to 4.01M33-2 will these emulators still work? They were working on 3.71M33-2

    Please Note: If I made any mistakes in making this post, please let me know and I will correct the error in the future. Again, sorry, but I can't search the forums, just trying to get some help. I would PM you Cheema, but I don't think I'm allowed with too few posts.

    Thanks for any help to anyone who can!

    PS - I hope I did the edit function correctly, if it keeps the original post and then adds the edit below and this becomes some ridiculous long post I am sorry. Guess I'll find out.
    Last edited by RememberingKarma; 08-12-2008 at 12:51 AM.
    Reply With Quote  
     

  13. #13  
    Senior Member PSP Elite Hacker cheema201's Avatar
    Join Date
    Jun 2008
    Posts
    1,042
    ok..

    I pretty much understand everything u are asking except for this bit

    Quote Originally Posted by RememberingKarma View Post
    Cheema I registered to the site to view the tutorial via your link to popsloader tutorial in your profile. It seems I can't run popsloader in 3.71M33-2, so now my questions is, if I plan to upgrade to 4.01M33-2 which CFW version of Popsloader should I DL? Will 3.80 or 3.90 work in 4.01M33-2? I notice this is the firmware you are running. (I have the .prx files I need, hopefully I can still use them after an update.
    if u mean can u load 3.80 or 3.90 pops from 4.01 then no u can not do that.. but if you mean can u install 3.80 popsloader (like i teach you how to in that guide) then yes u can do that.. you can only use prx files from 3.00 - 3.72

    and CWcheat will work fine on 4.01..

    as for ur other emulators u should have no problems.. just remember that if u have a fat to install 1.50 kernel for 4.01. however if u have a slim u wont have to worry about that..

    so upgrade to 4.01 and follow my popsloader guide...

    PS - I am going to put my popsloader guide on this site so ppl do not have to change sites to view it


    Tutorial
    Popsloader Installation guide
    Step by Step Popsloader installation guide


    Pandora for all PSP lovers.. this is wat we have been waiting for
    Pandora Linux Handheld


    Interested in having a little fun with the Final Fantasy games? Check out my code thread
    Exploiting Final Fantasy

    Final Fantasy 7 Remake
    Remake Final Fantasy 7 Petition
    Reply With Quote  
     

  14. #14  
    Junior Member PSP User
    Join Date
    Jul 2008
    Posts
    11
    Thanks for the reply Cheema!

    With the quoted part, I was basically asking, if I upgrade to 4.01M33-2 which Popsloader should I download? The site you link to has 3.80 version 2, are there other versions? If so which is the best to download if I plan to upgrade to 4.01M33-2?

    So if I have 4.01M33-2 CFW, and I also have popsloader I can load any popstation from 3.00 to 3.72, but I should also be able to use the popstation imbedded in the 4.01M33-2 CFW by loading "Popstation from Flash" right?

    Couple last questions, sorry, bear with me here.

    Will I still be able to emulate FFVII perfectly after updating to a higher CFW by loading the popstation from 3.71 via popsloader? And do you recommend running FFVII as each discs' eboot separately, or as one big 1.5Gb multidisc eboot?

    And finally, would you really recommend going to 4.01M33-2, or do you have another suggestion? I basically want as much PSX compatibility as possible. (it'd be nice if I could get Breath of Fire 4 running)

    Thanks so much for your help Cheema, I do greatly appreciate!!! Thank you, Thank you!
    Reply With Quote  
     

  15. #15  
    Senior Member PSP Elite Hacker cheema201's Avatar
    Join Date
    Jun 2008
    Posts
    1,042
    Upgrade to 4.01m33-2

    and install popsloader 3.80 version 2.. (its the latest version) it will work on ur 4.01 cfw...

    yes u will be able to run pops from 3.00 to 3.72 and yes u will be able to run 4.01 pops also... (you can also disable popsloader wenever u want as sometimes it hurts games, not many tho, ff8 is the only game that i disable popsloader for)

    i would not run ff7 as a multi disc eboot as it takes up memory.. simply run it as the 3 seperate discs. save it at the end of each cd so u can change discs without losing ur progress..

    with breath of fire 4.. u can run it with 3.51 pops or simply run it off ur flash from 4.01 and it will work.. (sometimes has problems wen loading saves on the world map, but once u have loaded a save once it will continue to work, just a once off glitch which u may never experience)

    I think that answers everything
    Last edited by cheema201; 08-12-2008 at 05:17 AM.


    Tutorial
    Popsloader Installation guide
    Step by Step Popsloader installation guide


    Pandora for all PSP lovers.. this is wat we have been waiting for
    Pandora Linux Handheld


    Interested in having a little fun with the Final Fantasy games? Check out my code thread
    Exploiting Final Fantasy

    Final Fantasy 7 Remake
    Remake Final Fantasy 7 Petition
    Reply With Quote  
     

Page 1 of 6 123 ... LastLast

Similar Threads

  1. gba emulator
    By j_b in forum PSP Software, Firmware & Plugins
    Replies: 0
    Last Post: 12-05-2008, 08:48 PM
  2. c64 psp emulator
    By mark00 in forum PSP Emulation
    Replies: 0
    Last Post: 12-04-2008, 06:50 PM
  3. Best emulator
    By slayer master in forum PSP Emulation
    Replies: 3
    Last Post: 06-07-2007, 01:45 AM
  4. PC emulator?
    By Jeremy Boyles in forum PSP Emulation
    Replies: 4
    Last Post: 04-05-2007, 10:44 AM
  5. Ps1 emulator for fw 2.60 help
    By blaze3927 in forum PSP Emulation
    Replies: 1
    Last Post: 04-03-2007, 01:11 AM
Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •