My psp was running 6.60 pro cfw I think, installed the firmware a few months ago. Anyway I just booted up a final fantasy VII eboot that ive used about 50 times before but it went straight from a black screen to the psp home menu showing all the options for the eboot. None of my buttons worked apart from the D-pad. So then I turned off my psp and turned it back on to get to the xmb. When I tried to boot the eboot again it complained about copyright. I checked in system information and my psp now has 6.60 ofw installed -_-

All my psx eboots wont boot because of copyright complaints, my previously working homebrew is now corrupt so cannot boot and also my legitimate psn game lbp on my memory stick wont boot and just sits on a black screen. I can boot my umd ratchet size matters but for some reason the home button wont work.

Somethings seriously messing with my psp, gonna try pandora's battery tomorrow but have you guys ever seen anything like this before?

This better not be sony's doing.

Thanks in advance guys