Thread: Looking to downgrade from 6.60, Snes9X not working properly

Results 1 to 6 of 6
  1. #1 Looking to downgrade from 6.60, Snes9X not working properly 
    Junior Member
    Join Date
    Oct 2012
    Posts
    3
    Currently on 6.60 PRO-B10 and both Snes9x Euphoria and Snes9x TYL haven't been running too smoothly. Was browsing around and it looks like people have had good luck with 6.20 CFW when it comes to snes emu's. I have the slim 2001, TA-085 v2. Any thoughts or suggestions would be appreciated. Thanks

    Dave
    Reply With Quote  
     

  2. #2  
    Senior Member I Modded My PSP
    Join Date
    Sep 2012
    Posts
    163
    use this:
    6.60 Downgrader Released, PSP Hacks - PSP Slim Hacks
    this home brew app only launches a update lower than what you have now so you need the actual 6.20 update file, get it from here:
    Installation - procfw - HowTo: Install PRO CFW on your PSP - X-Generation Aftermarket Firmware for Playstation Portable
    somewhere in the middle of the page us the 6.20 link,
    then launch the downgrader which will force launch the 6.20 update
    Reply With Quote  
     

  3. #3  
    Spambuster Bitch PSP Elite Hacker dankgame's Avatar
    Join Date
    Feb 2009
    Posts
    4,402
    i have ran snes on every custom firmware and snes emulator runs just fine your probly have bad roms and need new ones plus you can adjust the setting in the snes menu to over or underclock it and play with the FPS
    new members and old read thisvvvvvvvv
    http://www.pspmod.com/forums/introdu...uncements.html
    Reply With Quote  
     

  4. #4  
    Junior Member
    Join Date
    Oct 2012
    Posts
    3
    Quote Originally Posted by Timkl View Post
    use this:
    6.60 Downgrader Released, PSP Hacks - PSP Slim Hacks
    this home brew app only launches a update lower than what you have now so you need the actual 6.20 update file, get it from here:
    Installation - procfw - HowTo: Install PRO CFW on your PSP - X-Generation Aftermarket Firmware for Playstation Portable
    somewhere in the middle of the page us the 6.20 link,
    then launch the downgrader which will force launch the 6.20 update
    Awesome, thanks. I'll try that. I did a quick change to 6.60ME-1.8 and its running better but still not 100% so i'll try this for a few days then downgrade to 6.20.


    Quote Originally Posted by dankgame View Post
    i have ran snes on every custom firmware and snes emulator runs just fine your probly have bad roms and need new ones plus you can adjust the setting in the snes menu to over or underclock it and play with the FPS
    I'm trying out 6.60ME 1.8 and it seems to be running a bit better but still getting laggy video and audio. I know about the settings, but for some reason I am unable to change the clock. It's stuck on 333 Mhz. Changing the FPS helps. Also, I know the ROMs are good as these are the ones that I use for the emualtor on my Android phone and they run flawlessly on that.
    Reply With Quote  
     

  5. #5  
    Junior Member
    Join Date
    Oct 2012
    Posts
    3
    Hmmm.. not sure why my post from earlier today isn't showing up...

    Anyways, Thanks Timkl, I'll have to try that tomorrow when I get off of work.

    @ dankgame: I'm pretty sure the ROMs are good as they are the same ones that run perfectly on the emulator on my Android Phone. I went ahead and installed 6.60ME-1.8 and it seems to be running better but am having problems with loading save states so I might still go ahead and downgrade to 6.20 and try one of the CFWs for that. Hopefully it performs better.
    Reply With Quote  
     

  6. #6  
    Modder Of The Dark Arts PSP Elite Hacker R()H@X's Avatar
    Join Date
    May 2008
    Posts
    2,048
    6.60 me 1.8 and snes eurothopia runs flawless.if your having trouble its bad roms or your clock speed on your emulator or psp is slow.try making it 333 mhz.honestly tho i test before i respond to things and that snes should work fine on me 1.8 something else is going on if your having troubles
    Reply With Quote  
     

Similar Threads

  1. PSP Slim not working properly, anyone could help?
    By SkinnyV in forum PSP Modification
    Replies: 10
    Last Post: 01-09-2012, 06:07 PM
  2. Need help getting Nesterj working properly.
    By Cyclone112 in forum PSP Homebrew
    Replies: 4
    Last Post: 07-09-2010, 04:50 PM
  3. Psp 1001, analog nub not working properly
    By volvodude101 in forum PSP Hardware & Repair
    Replies: 4
    Last Post: 09-28-2009, 08:10 AM
  4. Help me get my Echochrome voucher working properly!
    By dairyinvader in forum PSP Discussion
    Replies: 1
    Last Post: 12-08-2008, 02:47 AM
  5. PSP and PSX Files Not Working Properly
    By Khoi in forum PSP Emulation
    Replies: 10
    Last Post: 05-14-2007, 08:20 PM
Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •