Thread: Western digital making me cry

Results 1 to 8 of 8
  1. #1 Western digital making me cry 
    Member PSP User eightshot's Avatar
    Join Date
    Aug 2008
    Posts
    69
    ok, in jan this year i bought 2 WD 500Gb external Hds one backs up the other synced every night, they have been fantastic up until about a weeks ago, when they BOTH died at exactly the same time

    the power supply is in 2 leads, the plug to the wall and another which attaches to the HD which also has a transformer of soughts on it with a green LED power indicator on that.

    i plug the normal plug in, no problem, plug that into the transformer the green LED lights up, as soon as i plug that into the HD the green LED fades and its the end of the story, no power,

    i have contacted WD and they have been about as useful as a fart in a space suit stating that my Hd models dont exist, and i have contacted currys who offered to take them off me and replace them with new HDs (no use there either).

    these HDs hold ALL my photogaphy, my music, my movies, CVs, Art......EVERYTHING, including my sisters wedding photos and some historical photos which the origionals of have been destroyed.

    i have tried in differant plug sockets, and USB port and the same fault is happeneing with both HDs,

    if anyone can help me it really would be appreciated,
    Reply With Quote  
     

  2. #2  
    Senior Member I Modded My PSP looneytoon's Avatar
    Join Date
    Mar 2008
    Posts
    167
    I didnt read your entire post (im lazy) but have you tried using a different computer? Try that and if it still doesnt work its not the hard drives.

    If you have the money, go on ebay and try to find the exact same harddrive, you could try a transplant, transfer the internal of the hard drive into a new body. Hope I was some help.


    LooneyElectronics.Com
    High Quality Pandora Battery & Memory Sticks - Low Prices - Fast Shipping From The USA - Personal Customer Service
    Reply With Quote  
     

  3. #3  
    Member PSP User felixtheswordsman's Avatar
    Join Date
    Apr 2008
    Posts
    66
    They're external, so maybe a short on the circut board inside the enclosure? That could explain why the light goes out when the drives are connected.

    If that IS the case, you could probably rip the casing off the HD's and just hook them up as internal drives.

    I'm no expert though, and I would hate for something to go wrong on account of my hunch...

    PSP Model 2001 (TA-85v2): 3.90 OFW -> 3.71m33 -> 3.90m33 -> 3.90m33-3 -> 4.01m33 -> 4.01m33-2 -> 5.00m33 -> 5.00m33-2 -> 5.00m33-3 -> 5.00m33-6 (NO BRICKS!)
    Reply With Quote  
     

  4. #4  
    Member PSP User eightshot's Avatar
    Join Date
    Aug 2008
    Posts
    69
    thanks for the input guys, problem is they don't make this particular HDD anymore, and have already tried flee bay, to avail.

    i will rip them open as a last resort but they are still in warranty and poof goes that if that happens

    keep the ideas comming , thanks guys (and gals)
    Reply With Quote  
     

  5. #5  
    Member PSP User
    Join Date
    Oct 2008
    Posts
    42
    Quote Originally Posted by felixtheswordsman View Post
    They're external, so maybe a short on the circut board inside the enclosure? That could explain why the light goes out when the drives are connected.

    If that IS the case, you could probably rip the casing off the HD's and just hook them up as internal drives.

    I'm no expert though, and I would hate for something to go wrong on account of my hunch...
    This would be my suggestion as well. MOST Externals you can take them apart, and use them as Internal, or slide them into a new enclosure. Worth a Shot. You got a pic of what the HDDs look like?

    I can judge better how hard it will be and if its safe to do.
    Reply With Quote  
     

  6. #6  
    Senior Member PSP Mad Hacker Daxmaurier's Avatar
    Join Date
    Sep 2007
    Posts
    513
    Not sure if it will help, but do you have any other powercords that you can try?
    PSP History
    V 2.81 -> Pandora -> 3.71 m33-2 -> 3.90 M33-3

    "Maybe... if you spend your life worrying... then the only way that your life will have meaning is if what you fear becomes real."

    Reply With Quote  
     

  7. #7  
    Member PSP User DisNerdGotSoul's Avatar
    Join Date
    Oct 2008
    Posts
    43
    i had the same thing happen to me on my maxtor hd. i tried the whole "making it internal" it was a no go. one thing i do is that, i don't leave it plugged in. like early this year i got my latest WD 500gig HD eventually, i figured, they don't have the same structural support as a cpu/laptop may have. so if i need something i'll plug it in, and if i don't need it, disconnect it.

    i hope everything else works out, but until then i'll mourn with you on your loss eightshot.
    "Feed The Soul, Starve The Ego" -DJ AM

    4.05 OFW -> 3.80 M33-5 CFW -> 4.01 M33-2 CFW
    Reply With Quote  
     

  8. #8  
    Senior Member I Modded My PSP itzzspencer's Avatar
    Join Date
    Jun 2008
    Posts
    478
    western digital fucked me in the ass 6 harddrives


    FW history: 3.95 -> 3.71 m33 -> 3.80 m33 -> 3.90M33-4 -> 4.01M33-2
    Reply With Quote  
     

Similar Threads

  1. digital comics on psp
    By bencowher in forum PSP Discussion
    Replies: 3
    Last Post: 12-05-2009, 09:14 PM
  2. This is Digital Art.
    By darkprodigy in forum Digital Art
    Replies: 7
    Last Post: 09-01-2009, 06:16 AM
  3. Where can I buy a psp digital camera.
    By PSP_Newb in forum PSP Discussion
    Replies: 1
    Last Post: 04-06-2008, 07:11 AM
  4. Using a digital camera on a psp?
    By ShOxXxa in forum Technical Discussion
    Replies: 1
    Last Post: 02-11-2008, 01:11 AM
  5. Mac and Western Digital External HDD issue
    By Nosympathy in forum Technical Discussion
    Replies: 1
    Last Post: 11-28-2007, 04:57 PM
Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •